Error: Some plugins are not available: Extensions/OpenWebif

Error: Some plugins are not available: Extensions/OpenWebif

Postnapisał silverchairbg niedziela, 31 grudnia 2017, 14:56

I am using latest PKT Hyperion 5.5 from Dec 8th 2017 and trying to install OpenWebif 1_2_7 from Plugins menu on Ipbox 55hd. The installation goes through fine, however, upon opening plugins menu, I get error: Some plugins are not available: Extensions/OpenWebif (No module named ipaddress). I've already found a thread that I should install python ipaddress module, but it just ain't working here:
ipbox55:# opkg install python-ipaddress
Unknown package 'python-ipaddress'.
Collected errors:

opkg_install_cmd: Cannot install package python-ipaddress.

I've tried to install it manually from https://pypi.python.org/pypi/ but get different errors:

ipbox55:/tmp/backport_ipaddress-0.1# python setup.py install
Traceback (most recent call last):
File "setup.py", line 1, in
from setuptools import setup, find_packages
ImportError: No module named setuptools

ipbox55:/tmp/ipaddress-1.0.19# python setup.py install
Traceback (most recent call last):
File "setup.py", line 7, in
from distutils.core import setup
ImportError: No module named distutils.core

Is there someway to get the 1.2.7 of OpenWebif to function on this image or you guys need to include the missing python module in a new build/hotfix?
silverchairbg
 
Posty: 13
Dołączył(a): niedziela, 31 grudnia 2017, 14:47
Dekoder:: IPBOX55

Re: Error: Some plugins are not available: Extensions/OpenWe

Postnapisał zukon niedziela, 31 grudnia 2017, 16:31

First upgrade firmware: blue/update/firmware
CZAS NIE &#%$!! NIE STANIE!


Tymczasowy link do pobierania wszystkich image PKT


NIE POMAGAM NA PW!!!
OGLĄDANIE PŁATNEJ TELEWIZJI BEZ OPŁACONEGO ABONAMENTU JEST PRZESTĘPSTWEM
Avatar użytkownika
zukon
Administrator
 
Posty: 8893
Dołączył(a): piątek, 6 marca 2009, 22:13
Lokalizacja: 3miasto
Dekoder:: GI XPeed LX3

Re: Error: Some plugins are not available: Extensions/OpenWe

Postnapisał silverchairbg niedziela, 31 grudnia 2017, 18:03

Ok, I thought that whatever is on the website is latest. Anyway, I upgraded firmware now and there is a new problem - not enough space on the ipbox 55hd to install the plugin, getting error: no space left on device. At the same time, I could not find a way to uninstall the old version of OpenWebif that came with the image, so I went ahead and deleted it directly from telnet:

ipbox55:~# du -sh /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif
8.7M /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif
ipbox55:~# rm -rf /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif

Now when I re-tried, I am able to install the new 1.2.7 OpenWebif and its settings work from the menu, but I get various errors, when I try to login to the web interface:

web.Server Traceback (most recent call last):
NameMapper.NotFound: cannot find 'webtv' while searching for 'mainMenu'
/usr/lib/python2.7/site-packages/twisted/web/server.py:183 in process
182
183
184
/usr/lib/python2.7/site-packages/twisted/web/server.py:234 in render
233
234
235
controllers/base.py:175 in render
174
175
176
controllers/base.py:80 in loadTemplate
79
80
81
/usr/lib/python2.7/site-packages/Cheetah/Template.py:1005 in __str__
1004
1005
1006
/home/zukon/DuckBox/oa-4.1-Hyperion5.7.1/builds/pkt/release/formuler3/tmp/work/all-oe-linux/enigma2-plugin-extensions-openwebif/enigma2-plugin-extensions-openwebif-1+gitAUTOINC+177b249319-r1/git/plugin/controllers/views/main.py:488 in respond
487
488
489
/home/zukon/DuckBox/oa-4.1-Hyperion5.7.1/builds/pkt/release/formuler3/tmp/work/all-oe-linux/enigma2-plugin-extensions-openwebif/enigma2-plugin-extensions-openwebif-1+gitAUTOINC+177b249319-r1/git/plugin/controllers/views/main.py:169 in mainMenu
168
169
170
NameMapper.NotFound: cannot find 'webtv' while searching for 'mainMenu'
silverchairbg
 
Posty: 13
Dołączył(a): niedziela, 31 grudnia 2017, 14:47
Dekoder:: IPBOX55

Re: Error: Some plugins are not available: Extensions/OpenWe

Postnapisał silverchairbg niedziela, 31 grudnia 2017, 18:11

Restart of the box resolved the error and now OpenWebif is working!!

Thanks for the quick help and have a great New Year celebration tonight!

Regards!
silverchairbg
 
Posty: 13
Dołączył(a): niedziela, 31 grudnia 2017, 14:47
Dekoder:: IPBOX55


Powrót do Image PKT

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 6 gości